Совместимость дополнений с Firefox 3.6 на примере Roboform.

28 Янв
2010


Я один из многих поклонников интернет браузеров Mozilla Firefox, но как и многие пользователи постоянно сталкиваюсь с проблемой совместимости новых версий Firefox с различными дополнениями.

Для работы с паролями я использую программу Roboform которая защищает и помнит все мои пароли и тулбар панель встраивается в Firefox. Каждый раз с новым обновлением эта панель исчезает с панели браузера и я некоторое время ищу решение проблемы, чтобы вернуть его на место.

Это очень неприятно и неудобно, когда за паролями нужно лезть в программу и искать их в ней.

В этот раз я потратил несколько дней для поиска также решение проблемы с Roboform и Firerox 3.6 и сегодня оно было найдено.

Итак, для начала определяем свою собственную версию браузера, зайдя в Справка - О Mozilla firefox.

firefox-roboform

После того как мы выяснили какая версия браузера у вас, делаем следующее. Открывает новую вкладку и вводит в адресную строку следующее значение: about:config и жмём Enter

about_config_firefox

У нас открывается предупреждение  Firefox.

preduprezgdenie_about

Я думаю в нём ясно написано, чтобы вы не вмешивались в те настройки которые вы не понимаете. Но так как у нас есть эта инструкция, всё будет хорошо. Идём далее, и жмём Я обещаю, что буду осторожен!

У Вас открываются config файлы с которыми нужно быть осторожными.

На любой строке, жмём правой кнопкой мыши и открываем меню. Нам необходимо создать Логическое. Ниже на рисунке показано что именно нам нужно:

logicheskoe

Далее, в поле, которые у вас откроется после нажатия на Логическое, необходимо ввести следующее:

extensions.checkCompatibility.3.6 где вместо 3.6 вам необходимо вставить версию своего браузера. Только версию необходимо вписывать полностью, как в Справке у вас указано.

Получиться должно примерно следующее:

image120

Жмёте  Ок, и на следующем поле выбираете значение false

image121

У Вас должна появиться примерно следующая строка:

config_dopolnenia

После этого ваши дополнения должны приступить к установке. Можете зайти в Дополнения и посмотреть. Обычно вас попросят перезапустить браузер после этого. Статью эту рекомендую кинуть в закладки, чтобы если что, смогли ещё раз всё перепроверить.

Проблема бывает если вы неверно определили и вписали версию программы. У меня всё заработало, и после перезапуска панель Roboform появилась на своём прежнем месте в Firefox.

Если всё выше написанное лень делать, просто идём сюда и ставим адаптер roboform к firefox и всё будет работать.

Самые комментируемые записи

  • Добавь в закладки:

    Google Bookmarks Digg Reddit del.icio.us Ma.gnolia Technorati Slashdot Yahoo My Web News2.ru БобрДобр.ru RUmarkz Ваау! Memori.ru rucity.com МоёМесто.ru Mister Wong

  • 

    25 Комментариев к Совместимость дополнений с Firefox 3.6 на примере Roboform.

    Аватар

    Flex

    Февраль 9th, 2010 | 14:36

    Ну да, просто-напросто, отключаем проверку на совместимость…
    Впочем. иногда действительно проще выключить. чем копаться каждый раз

    [Ответить]

    Аватар

    петя

    Март 13th, 2010 | 13:24

    А ВОТ И НЕ ЗАРАБОТАЛО. ВСЕ СДЕЛАЛ ВЕРНО

    [Ответить]

    Анатолий Виноградов Reply:

    Всё нормально работает, недавно снова переустанавливал. Скачайте с оф. сайта специальный файл, который и позволит нормально работать roboform в firefox. Ставится как дополнение.

    [Ответить]

    Аватар

    Щёлоков Санек

    Март 15th, 2010 | 22:57

    Огромное тебе спасибо человеческое АФТАР сколько же это не совместимость приносит хлопот,спасибо что потратил только время для нас и себя.У меня почему то не с первого раза фишка сработала,но не стал отчаиваться повторил и все как описано было.Еще раз СПАСИБО.

    [Ответить]

    Аватар

    Павел

    Март 18th, 2010 | 00:42

    Когда обновлял мозилу знал, что с робоформом наверняка будут проблемы. Но знал что найдутся добрые люди которые поделятся способом решения этой проблемы. Все получилось с первого раза. Спасибо тебе за труды.

    [Ответить]

    Аватар

    Сергей

    Март 22nd, 2010 | 06:40

    Даже с вашей инструкцией и адаптером робо не зароботал =\ (наверно руки кривые)
    Поэтому советую просто использовать ехе-установщик с офф. сайта, он сам устанавливает адаптер (главное галочку не убирать ;) )

    [Ответить]

    Аватар

    Светлана

    Март 24th, 2010 | 11:53

    Супер!!! Спасибо огромное - ВСЁ работает!!!!!!

    [Ответить]

    Аватар

    asPrn

    Март 29th, 2010 | 16:29

    Отлично! Все работает!

    [Ответить]

    Аватар

    ПрохожийНепохожий

    Май 7th, 2010 | 14:13

    Сработал адаптер который ставится автоматически с официального сайта. Идем сюда [ссылка] и ставим адаптер для версии 3.0

    [Ответить]

    Аватар

    Nady

    Май 29th, 2010 | 11:28

    Заработало!!!!!! Правда, не совсем сразу,но таки заработало!!!!!!
    Я устанавливала другое дополнение. не робо.
    СПАСИБО-СПАСИБО-СПАСИБО-СПАСИБО автору!!!!!!!!!

    [Ответить]

    Аватар

    alex

    Июнь 11th, 2010 | 21:51

    Спасибо всё сделал как описано выше но не заработала сразу установил ещё АДАПТЕР от сюда [ссылка] для своей версии и всё ок!!! Ещё раз спасибо!

    [Ответить]

    Анатолий Виноградов Reply:

    Вобщем адаптер решает проблему совместимости. Инструкцию писали когда ещё не было адаптера, либо не знали о нём. Инструкция универсальная и возможно пригодится ещё когда то при смене версии браузера.

    [Ответить]

    Аватар

    Olga

    Июль 15th, 2010 | 21:12

    Как теперь все исправить!!!!!!!????????? Постоянно выскакиевает ошибка, сто раз переустанавливала. теперь с робоформом вообще никак работать не хочет!

    [Ответить]

    Анатолий Виноградов Reply:

    Идите по этой ссылке установите адаптер к firefox и всё будет работать как раньше.

    [Ответить]

    Аватар

    Olga

    Июль 17th, 2010 | 14:03

    Дело в том, что я все-таки нашла способ, чтоб эта ошибка, которая постоянно выскакивала и закрывала мозиллу, пропала. Но, боюсь, что когда снова установлю робоформ, ошибка снова будет выскакивать. Этот адаптер поможет?

    [Ответить]

    Аватар

    Olga

    Июль 17th, 2010 | 15:18

    переустановила полностью браузер, как написано на сайте по ссылке - не помогло!!! теперь когда устанавливаю расширение roboform, все равно не работает и пишет такие ошибки [ссылка]
    после чего мозилла сама вырубается
    если в настройках в дополнениях отключаю расширение roboform, то работает нормально.
    скажите, как настроить мозилу, чтобы было как раньше??????????? то есть до того, как я зашла в about:config???????? как удалить все то, что я установила, все эти адаптеры, фолс и так далее? потому как до установки всего этого, когда в расширениях старой версии мозиллы стоял робоформ, он работал, а как установила новую и последовала вашему совету, с тех пор появляются эти окна с ошибками.

    [Ответить]

    Анатолий Виноградов Reply:

    Ольга, так вам пишется же в ошибке, что у вас старая версия робоформа 6-3-7, а адаптер вы ставите от 6,9,93.
    Сохраните все паскарты и установите свежую версию робоформа, их в сети хватает. Если вы уверены что именно те изменения которые вы внесли и есть причина ошибка, верните всё назад, проделав в точности наоборот, согласно инструкции. Хотя мало вероятно что в этом причина.

    [Ответить]

    Аватар

    Olga

    Июль 18th, 2010 | 11:31

    Ой, получилось) Теперь нет этих ужасных ошибок) Проблема была в том, что я устанавливала робоформ не свой (с инета или сиди), а на оф сайте мозиллы. Думала, так как проверка на совместимость отключается, то и старая версия будет работать. Теперь вот буду знать)

    [Ответить]

    Анатолий Виноградов Reply:

    Хорошо то ,что хорошо кончается.

    [Ответить]

    Аватар

    Александр

    Июль 30th, 2010 | 19:44

    Большое спасибо автору,вся установка прошла очень замечательно!
    С уважением,Александр

    [Ответить]

    Аватар

    Геннадий

    Январь 8th, 2011 | 22:58

    С версиями 3.6.10 и 3.6.13 этот метод не заработал.

    [Ответить]

    Аватар

    Сергей

    Февраль 2nd, 2011 | 17:01

    Большое спасибо тебе добрый человек… у меня мазила вер. 3.6.12 Roboform вер. 6.9.87 –заработало !

    [Ответить]

    Аватар

    Ирина

    Февраль 13th, 2011 | 18:32

    огромное спасибо!!!долго не могла решить эту проблему!!

    [Ответить]

    Аватар

    Виктор

    Январь 13th, 2015 | 11:50

    Благодарен и признателен автору и всем участникам обсуждения проблемы. Всё заработало как надо!

    [Ответить]

    Аватар

    [ссылка]

    Декабрь 11th, 2018 | 08:42

    These are really wonderful ideas in regarding blogging. You have
    touched some pleasant things here. Any way kerp up wrinting.

    [Ответить]

    Комментировать

    Dofollow комментарии! Но оставляем, только осмысленные.

    Наверх